Notice: Purchasing, Trials and Accounts Have Changed. What You Need To Know: Part II >>

Topic - ETEREA UV Tools 3.5 • Updated January 14, 2014

Page 1 of 7
   1  2  3  4  5  6  7  Next  Last 
Update January 14, 2012

— Very small update: the top-left align icon was wrong. Just a small change on “etereaUVtools_iconsgrid.CFG”. Now is fixed.

Update December 23, 2013 • Version 3.5

— Icons are defined using the new 'Icons Grid' structure introduced with Modo 701. This means a better file management: Modo does not import a lot of small PNG files, one for each icon. There are just 2 'grid image' files now, one for medium icons (20 pixels) and one for large icons (32 pixels).

— I provide an alternate old version, compatible with Modo 601, but I won't update this, sorry.

— Now you can open the tools in two ways: as a Popover (simple CLICK on icon in top Toolbar) or as a Floating Window (press ALT at the same time)

— New tools added for UVDestroy, Fix UV Islands and Split UVs (see CREDITS for more details)

------------------------------------------------------------------------------------------------------------------------------

(Old) info about utilization and integration with Modo interface on this 50 min videotutorial (Spanish language)

------------------------------------------------------------------------------------------------------------------------------

Here is the latest version for “Eterea UV Tools”. As you can see on the screencapture, this is a big update, with lots of new tools. Please: over your mouse over each tool to read descriptions and small guide.



CREDITS

Third part scripts included on this package (full credits have been added on the scripts head code, when needed):

• uvIslandPack and loadImageMap by Mark Rossi aka Onim.

• toggleUVxxxxx scripts based on toggleUVImage by Mark Rossi aka Onim.

• uv2weight, uvaligner2 and uvSelectDiscoEdge by Take-Z.

• UVBlockAligner_11 created by Take-Z, modified by Richard Rodriguez aka gm770, updated by Dongju.

• move1step_uv by MonkeyBrotherJr

• orient_UV_shell by Mario Baldi

• quickAlignUVs and splitUV by James O'Hare aka Farfarer

• FixUVisland by Dmitry Bersenev aka Mynglam

• uvDestroy by Seneca Menard

NOTE: I hope not to annoy any third part scripter by including your script with this package. It's only to give an easier solution to users, in a form of a complete kit. If you don't like this idea, just drop me a note and I will remove your script form here. No problem at all :-)

Big thanks to users on this forum that helped with this toy! ;-)

Icons, LXM macros and palette design by Cristóbal Vila aka Etérea.


INSTALLATION

>>> Download EtereaUVTools 3.5 <<< Compatible with Modo 701 and up

>>> Download EtereaUVTools 3.3 <<< Compatible with Modo 601

— Download and unzip the file.
— Move the resulting folder to User Scripts folder (*)
— Open Modo

(*) Move the entire kit Folder, not inner separate contents. And do not rename that folder. If you are not sure about where is that user “Scripts” folder in your system, do this: open Modo > Menu System > Open User Scripts Folder (and close Modo)

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

ETEREA MODO RESOURCES · You will find there all my shared tools and kits, with information in English and Spanish

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Cristóbal Vila
etereaestudios.com

Message edited by Cristobal Vila on 6/26/2014 - 4:30 AM

Looks very cool, Eterea, nice job! You might delay releasing this for a few hours if you can, because later tonight I can modify my script to allow for relative path referencing so that the end user won't have to modify the configs to specify the image file paths. Also I can add the shading mode change.
thank you very much Eterea and Onim

Laurent
Quote from Onim :
Looks very cool, Eterea, nice job! You might delay releasing this for a few hours if you can, because later tonight I can modify my script to allow for relative path referencing so that the end user won't have to modify the configs to specify the image file paths. Also I can add the shading mode change.


DONE!
Once you update your script I will update this package.
And so is better for users... Guys: be patient :-)
Now this seems a teaser :-)))

Cristóbal Vila
etereaestudios.com

Message edited by Cristobal Vila on 1/13/2011 - 10:34 PM

OK, I can't test it just now but I should be able to in maybe an hour or two, so I'll upload it then.
Don't worry, Onim. Take your time. No stress :-)
Here is almost 22.00 h, I will probably update this by tomorrow...

Cristóbal Vila
etereaestudios.com

Cristobal and Onim: NO WAY FOR TOMORROW guys. Do it now !! (just kidding)

Laurent
OK, I updated it. By the way, for the file path you can use either /'s or \'s, it doesn't really matter because the script should sort it out for you. So if you intend the user to put the UV checker images in the default modo scripts directory, you can use either "scripts:\filename.ext" or "scripts:/filename.ext" for your form buttons.
 
  • Pascal Beeckmans - Montreal
  • 1329 posts
Wow that's a super combo, looks super fun to use.

Thanks a lot guys :)
OK, all is inside the box right now. Thanks for your quick movements, Mark.
If something fails, I will fix/update tomorrow. Now is time to go sleep :-)
Hope you find it useful.

Cristóbal Vila
etereaestudios.com
Hi guys,

For Win users: could you confirm if this thing works well on your systems?

(I have received a comment on my blog saying that it doesn't work on a Wintel machine)

Thanks for your feedback.

Cristóbal Vila
etereaestudios.com
Quote from Eterea :
Hi guys,

For Win users: could you confirm if this thing works well on your systems?

(I have received a comment on my blog saying that it doesn't work on a Wintel machine)

Thanks for your feedback.

Cristóbal Vila
etereaestudios.com


Works OK here.

Copy contents of "echar_contenidos_en_CONFIGS" to -> %appdata%\Luxology\Configs

Copy contents of "echar_contenidos_en_SCRIPTS" to -> %appdata%\Luxology\Scripts
Thanks, Onim.

It seems that there are more Win users having problems both with the icons loading and the “loadImageMap.py” calling to checkgrids.

Not sure if this could be something related with the slashes (\) and (/)? Maybe only in older Win systems? :-/

Thanks for your input.

Cristóbal Vila
etereaestudios.com
works great on osx here. very useful. thanks again

Laurent
Yes, Laurent, on OSX it works correctly.
The problem seems to appear only at (some, not all) Windows systems (?)

Cristóbal Vila
etereaestudios.com
Quote from Eterea :
Thanks, Onim.

It seems that there are more Win users having problems both with the icons loading and the “loadImageMap.py” calling to checkgrids.

Not sure if this could be something related with the slashes (\) and (/)? Maybe only in older Win systems? :-/

Thanks for your input.

Cristóbal Vila
etereaestudios.com

The script accounts for the different slashes used in OSX and Windows, so that shouldn't be the issue. I'd have to know what the error messages are, but then the fact that people are also having problems loading the icons suggests that it's not a problem with the script. My guess is that they are copying the subdirectories themselves into the configs and scripts directories, rather than the contents of the subdirectories. That is, maybe their directory structure is:

%appdata%\Luxology\Scripts\echar_contenidos_en_SCRIPTS\icons

when instead it should be:

%appdata%\Luxology\Scripts\icons
Bingo! The problem is with 401.
I have tried with 401 (on a Mac) and it doesn't work :-/
I can not understand why.

Maybe the forms created with 501 are no backwards compatible?

Cristóbal Vila
etereaestudios.com
Yep, it appears so. Probably the easiest solution would be to recreate the forms in 401. My scripts are compatible with 401.
Looking at the form created and saved with 501 it says:

<atom type="IconImage">icons/uv_view_tx.png</atom>

Install this in 401 doesn't work.
And changing by hand the icon path (using the Form editor) and re-saving this form using 401 it says (when reading with a text editor):

<atom type="IconImage">/Users/cristobal/Library/Application Support/Luxology/Scripts/icons/uv_view_tx.png</atom>

By this way it works in 401. And NO other thing changes between 401 and 501 CFG

Maybe using this:

<atom type="IconImage">User:Scripts/icons/uv_view_tx.png</atom>

It could work with 401 and 501?

I will made further tests...

Cristóbal Vila
etereaestudios.com

Hi,

I followed all instructions but didn't found where to launch it ...

Could you explain it in english please because not easy in spanish in your Blog

modo 501 - windows 7 x64

Thanks
Phil

Message edited by wireframex on 1/16/2011 - 11:34 PM

Quote from Onim :
Yep, it appears so. Probably the easiest solution would be to recreate the forms in 401. My scripts are compatible with 401.


Changing:

<atom type="IconImage">icons/uv_view_tx.png</atom>

by

<atom type="IconImage">User:Scripts/icons/uv_view_tx.png</atom>

and all icons load perfectly in Modo 401 (at least on my Mac). PERFECT.

The problem now is:

How I must edit the line for the script-checkgrid callers?

The Form saved with 501 says:

<list type="Control" val="cmd @loadImageMap.py "Texture" "scripts:/checkgrids/medium.png" swap top shade:texmod">

I have tried this option with 401, without success:

<list type="Control" val="cmd @loadImageMap.py "Texture" "User:Scripts/checkgrids/medium.png" swap top shade:texmod">

Ideas?

(Sorry, Wireframex, be patient with the installation instructions. I am trying to investigate the problems with 401. In the meantime use the Google translator, at right on my blog, anyway not a detailed step by step...no time... sorry)

Cristóbal Vila
etereaestudios.com

Message edited by Cristobal Vila on 1/16/2011 - 11:54 PM

Quote from Eterea :

(Sorry, Wireframex, be patient with the installation instructions. I am trying to investigate the problems with 401. In the meantime use the Google translator, at right on my blog, anyway not a detailed step by step...no time... sorry)
Cristóbal Vila
etereaestudios.com

Ok I will try it
Thanks
OK, spoke too soon about compatibility with 401, since adding the support for modo path aliases there is a slight issue. Long story short, that entry should be:

<list type="Control" val="cmd @loadImageMap.py "Texture" "user:/scripts/checkgrids/medium.png" swap top shade:texmod">

The problem is that in 401 there are no aliases for scripts or configs, so you have to use the alias for the parent directory (user). So instead of using scripts:/ in the file arguments for my script, use user:/scripts/. I will upload a new version of my LoadImageMap, it also includes a small fix so that texture display persists in the UV window when swapping images.

Message edited by Onim on 1/17/2011 - 12:28 AM

Thanks for the update, Onim :-)

Cristóbal Vila
etereaestudios.com
I have update the first post with a new version, V1.2. Now it works both on my 401 and 501 (on my Mac) and it includes the new script version by Onim. Please, Win users: confirm if now it works on you 401/501 systems.

To Wireframex: I have included a small installation guide in the first post.

Hope you enjoy this.

Cristóbal Vila
etereaestudios.com

Message edited by Cristobal Vila on 1/21/2011 - 5:48 PM

Page 1 of 7
   1  2  3  4  5  6  7  Next  Last